Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

As of November 2017, the minimum supported version of libsrtp supported by Asterisk is 1.5.4.  Earlier versions may allow Asterisk to compile but there were enough issues that earlier versions MAY CRASH, will NOT BE SUPPORTED and are used at your own risk.Both   Both Asterisk and pjproect do support libsrtp 2.x but we've not tested extensively with it so your safe bet is to stick with 1.5.4 for production builds and use ./configure .

Make sure to specify --with-pjproject-bundled (of course)  when running ./configure to make sure both Asterisk and pjproject are in sync with respect to library versions.

...