Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

For SIPp, we'll need to download the source and build it ourselves, as we'll want both pcap and openssl support.  The current minimum version required is 3.4.1.

  1. Enter the following:

    Code Block
    bash
    bash
    $ mkdir sipp
    $ cd sipp
    $ wget httphttps://sippgithub.sourceforge.netcom/snapshotsSIPp/sipp.2009-07-29./archive/v3.4.1.tar.gz
    Resolving sipp.sourceforget.net...
    Connecting to sipp.sourceforget.net
    ...
    $ tar -zxvf sipp.2009-07-29.v3.4.1.tar.gz
    $ cd sipp-3.svn4.1
    $ make pcapplay_ossl
    ./configure --with-pcap --with-openssl
    $ sudo cp sipp make install
    

    By default, sipp is installed in /usr/

    bin

    local/bin.  If you want it installed to /usr/bin, add '–prefix=/usr' to the configure command.

     

  2. Verify that sipp is installed and configured correctly:

    Code Block
    bash
    bash
    $ sipp -v
    
    SIPp v3.4.1-TLS-PCAP, version unknown, built -RTPSTREAM ...
    
  3. When finished, return to the testsuite directory

    Code Block
    bash
    bash
    $ cd ../..
    

...