Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 43 Next »

1. Introduction

Installing a binary distribution of Asterisk makes it easier to maintain your system. Using the package management tools that are included with your Linux distribution, you can install and update software without manually managing dependencies (libraries and utilities on which applications rely).

Currently Asterisk is available for automated binary installation using APT for Debian and Ubuntu or YUM utility on CentOS 5 Linux and RedHat Enterprise Linux 5.

2. APT (Debian / Ubuntu)

Warning

Icon

As of March, 2012 the Debian / Ubuntu packages are unmaintained. Please consider using your local operating system Asterisk packages.

The goal with the deb repositories is simply to provide the latest Asterisk versions, such as Asterisk 1.8, for older versions of distributions where distribution policy prohibits incorporating our latest version. As of now, we have Asterisk packages available for the following distribution versions:

  • Debian Squeeze (stable)
  • Debian Wheezy (testing)
  • Ubuntu Lucid (10.04)
  • Ubuntu Maverick (10.10)
  • Ubuntu Natty (11.04)
  • Ubuntu Oneiric (11.11)

2.1. Prerequisites

2.1.1. Dependencies

2.1.2. Importing the public key

Note

Icon

If you are having problems downloading the key from pgp.mit.edu, try the following:

2.2. Adding the release branch

2.2.1. Adding the repository

2.3. Adding the proposed branch (Optional)

The proposed branch includes updates which are waiting to be moved into the release branch after some testing. They may never reach recommended or they may be replaced with a more recent update. Enabling this is reasonable if you want to participate in testing minor updates, or know that your specific problem has been solved here but the package hasn't reached recommended yet.

2.3.1. Adding the repository

2.4. Installing Asterisk

2.4.1. Update APT

2.4.2. Asterisk

2.4.3. DAHDI

All DAHDI related components of Asterisk have been moved to a separate package. For example if you want to use app_meetme.so, then you need to install this package.

2.5. Upgrading Asterisk

2.5.1. Asterisk

Note

Icon

Due to a bug in asterisk-1.8.3 of the packages, upgrading to later versions of Asterisk will not work. Unfortunately you will need to purge the previous version and install asterisk again.

3. YUM (CentOS 6 / Red Hat Enterprise Linux 6)

3.1. Prerequisites

3.2. Adding the repository

3.3. Installing

3.3.1. Asterisk

3.3.1.1. 1.8

3.3.1.2. 11

3.3.2. DAHDI

3.4. Upgrading

  • No labels